Add mihawk sensor, fan control and d-bus monitor

Most of mihawk's sensors are different from witherspoon, so I temporarily
added the mihawk part and did not change the witherspoon.

Add mihawk version of fan control and d-bus monitor.
Mihawk does not have a water cooled mode, so another independent folder is added.

Tested: 1.Shut down the system if more than three cores
          have a temperature greater than 100 degrees Celcius.
        2.Fan control support cpu core, dimm, Onboard.
        3.Confirm that sensor is able to return normally via REST.

Signed-off-by: Ben Pai <Ben_Pai@wistron.com>
Signed-off-by: Brad Bishop <bradleyb@fuzziesquirrel.com>
Change-Id: I346fd70fe435eef4a745dc5863ce023037e0f151
diff --git a/meta-witherspoon/recipes-phosphor/dbus/phosphor-dbus-monitor_%.bbappend b/meta-witherspoon/recipes-phosphor/dbus/phosphor-dbus-monitor_%.bbappend
index 8e1bf41..5c9d0b1 100644
--- a/meta-witherspoon/recipes-phosphor/dbus/phosphor-dbus-monitor_%.bbappend
+++ b/meta-witherspoon/recipes-phosphor/dbus/phosphor-dbus-monitor_%.bbappend
@@ -1 +1,2 @@
 SYSTEMD_LINK_phosphor-msl-verify_append_ibm-ac-server = " ../phosphor-msl-verify.service:obmc-chassis-poweron@0.target.requires/phosphor-msl-verify.service"
+SYSTEMD_LINK_phosphor-msl-verify_append_mihawk = " ../phosphor-msl-verify.service:obmc-chassis-poweron@0.target.requires/phosphor-msl-verify.service"