wspoon: Use machine in file path append for fans

In preparation for additional systems under the witherspoon layer, add
the machine name as a prefix to the phosphor-fan* configuration
directories. This allows additional machines' phosphor-fan*
configurations to be placed in this layer.

Tested:
    Witherspoon phosphor-fan image still contains applications &
    phosphor-fan applications are correctly configured.

Change-Id: I1a8d9bf0b9cfe05724277d107e482e7c06f2a6c1
Signed-off-by: Matthew Barth <msbarth@us.ibm.com>
diff --git a/meta-witherspoon/recipes-phosphor/fans/phosphor-fan_%.bbappend b/meta-witherspoon/recipes-phosphor/fans/phosphor-fan_%.bbappend
index f2878fb..e28bcb1 100644
--- a/meta-witherspoon/recipes-phosphor/fans/phosphor-fan_%.bbappend
+++ b/meta-witherspoon/recipes-phosphor/fans/phosphor-fan_%.bbappend
@@ -1,4 +1,6 @@
 FILESEXTRAPATHS_append := "${THISDIR}/${PN}:"
+# Machine specific files override shared files with the same name
+FILESEXTRAPATHS_prepend := "${THISDIR}/${MACHINE}-${PN}:"
 
 # Package configuration
 FAN_PACKAGES += " \