meta-ibm: palmetto: override variable assignments

Add overrides to variable assignments as described in "Modify Variables
to Support a Different Machine" in the yocto development tasks manual:
https://www.yoctoproject.org/docs/latest/dev-manual/dev-manual.html#best-practices-to-follow-when-creating-layers

In a nutshell this allows multiple BSP layers to be included
simultaneously in bblayers.conf, which increases the potential for meta
data sharing between layers.

Change-Id: I27a8382d530add3021b7fe4769dfe222eb2469e8
Signed-off-by: Brad Bishop <bradleyb@fuzziesquirrel.com>
diff --git a/meta-palmetto/recipes-phosphor/host/checkstop-monitor.bbappend b/meta-palmetto/recipes-phosphor/host/checkstop-monitor.bbappend
index 72d991c..2d33559 100644
--- a/meta-palmetto/recipes-phosphor/host/checkstop-monitor.bbappend
+++ b/meta-palmetto/recipes-phosphor/host/checkstop-monitor.bbappend
@@ -1 +1 @@
-FILESEXTRAPATHS_prepend := "${THISDIR}/${PN}:"
+FILESEXTRAPATHS_prepend_palmetto := "${THISDIR}/${PN}:"