Remove the insecure protocols from the cipher List

The cipher_list.json for Witherspoon is updated to support only
Cipher suite 3 and 17. This will be consumed by Get Channel Cipher
Suites command and Get LAN configuration command, to publish the
supported cipher suites.

Change-Id: Ica210d1f40424344e9a595335c31ffb31dde89a3
Signed-off-by: Tom Joseph <tomjoseph@in.ibm.com>
diff --git a/meta-witherspoon/recipes-phosphor/ipmi/witherspoon-ipmi-config.bb b/meta-witherspoon/recipes-phosphor/ipmi/witherspoon-ipmi-config.bb
index 8ab47c6..2737a04 100644
--- a/meta-witherspoon/recipes-phosphor/ipmi/witherspoon-ipmi-config.bb
+++ b/meta-witherspoon/recipes-phosphor/ipmi/witherspoon-ipmi-config.bb
@@ -4,12 +4,15 @@
 inherit obmc-phosphor-license
 inherit allarch
 
+FILESEXTRAPATHS_prepend := \
+"${THISDIR}/../../../../../../meta-phosphor/common/recipes-phosphor/ipmi/phosphor-ipmi-config/:"
+
 SRC_URI = " \
     file://cipher_list.json \
-    file://dcmi_cap.json \
-    file://dcmi_sensors.json \
-    file://dev_id.json \
-    file://power_reading.json \
+    file://witherspoon/dcmi_cap.json \
+    file://witherspoon/dcmi_sensors.json \
+    file://witherspoon/dev_id.json \
+    file://witherspoon/power_reading.json \
     "
 
 FILES_${PN} = " \
@@ -56,7 +59,7 @@
         auxVer = count[0] + "0000"
 
     workdir = d.getVar('WORKDIR', True)
-    file = os.path.join(workdir, 'dev_id.json')
+    file = os.path.join(workdir, 'witherspoon/', 'dev_id.json')
 
     # Update dev_id.json with the auxiliary firmware revision
     with open(file, "r+") as jsonFile:
@@ -71,12 +74,12 @@
     install -d ${D}${datadir}/ipmi-providers
     install -m 0644 -D ${WORKDIR}/cipher_list.json \
         ${D}${datadir}/ipmi-providers/cipher_list.json
-    install -m 0644 -D ${WORKDIR}/dcmi_cap.json \
+    install -m 0644 -D ${WORKDIR}/witherspoon/dcmi_cap.json \
         ${D}${datadir}/ipmi-providers/dcmi_cap.json
-    install -m 0644 -D ${WORKDIR}/dcmi_sensors.json \
+    install -m 0644 -D ${WORKDIR}/witherspoon/dcmi_sensors.json \
         ${D}${datadir}/ipmi-providers/dcmi_sensors.json
-    install -m 0644 -D ${WORKDIR}/dev_id.json \
+    install -m 0644 -D ${WORKDIR}/witherspoon/dev_id.json \
         ${D}${datadir}/ipmi-providers/dev_id.json
-    install -m 0644 -D ${WORKDIR}/power_reading.json \
+    install -m 0644 -D ${WORKDIR}/witherspoon/power_reading.json \
         ${D}${datadir}/ipmi-providers/power_reading.json
 }