phosphor-ipmi-host: Move configuration to phosphor-ipmi-config

Witherspoon requires an dev_id.json file whose content is partially
derived from data provided by the os-release package. os-release is
updated for each commit, as some of its content (VERSION and
VERSION_ID) can be derived from `git describe`. As dev_id.json was
provided by the phosphor-ipmi-host package, every commit transitively
triggered a rebuild of phosphor-ipmi-host in order to satisfy
Witherspoon's requirements.

Always rebuilding phosphor-ipmi-host is unhelpful for several reasons:

* It needlessly reduces CI throughput, as it is likely the commits in
  question do not modify the phosphor-ipmi-host package.
* GCC suffers from what appears to be an unfixable[1] bug[2] that causes
  phoshor-ipmi-host to consume large (>5GiB) amounts of RAM when
  compiling some (at least Witherspoon) sensor configurations.

To avoid this, separate the configuration files out into
virtual/phosphor-ipmi-config and phosphor-ipmi-config packages that
phosphor-ipmi-host RDEPENDS on. Witherspoon provides an alternative
implementation in witherspoon-ipmi-config to mangle dev_id.json to its
particular requirements.

A virtual is used rather than a simple bbappends for Witherspoon, as the
bbappend approach breaks builds of machines other than Witherspoon if
Witherspoon is built first: The Witherspoon-specific dev_id.json file is
deployed in its mangled form into e.g. a Zaius image. Specifically, the
following sequence will trigger the issue:

    $ TEMPLATECONF=.../witherspoon.conf . openbmc-env
    $ bitbake obmc-phosphor-image
    $ rm -rf conf
    $ TEMPLATECONF=.../zaius.conf . openbmc-env
    $ bitbake obmc-phosphor-image

[1] https://gcc.gnu.org/bugzilla/show_bug.cgi?id=80290#c26
[2] https://gcc.gnu.org/bugzilla/show_bug.cgi?id=80290

Change-Id: Ib9629fc77b29e2deeab3f1c3a145d9e966c14ec4
Signed-off-by: Andrew Jeffery <andrew@aj.id.au>
diff --git a/meta-witherspoon/recipes-phosphor/ipmi/phosphor-ipmi-host.bbappend b/meta-witherspoon/recipes-phosphor/ipmi/phosphor-ipmi-host.bbappend
index 27678bf..748fa73 100644
--- a/meta-witherspoon/recipes-phosphor/ipmi/phosphor-ipmi-host.bbappend
+++ b/meta-witherspoon/recipes-phosphor/ipmi/phosphor-ipmi-host.bbappend
@@ -1,49 +1,5 @@
 FILESEXTRAPATHS_append_witherspoon := ":${THISDIR}/${PN}"
-SRC_URI_append_witherspoon = " file://occ_sensors.hardcoded.yaml \
-                               file://dev_id.json \
-                               file://dcmi_sensors.json \
-                               file://power_reading.json \
-                               file://hwmon_sensors.hardcoded.yaml \
-                               file://cipher_list.json \
-                             "
-inherit image_version
-
-# Calculate the auxiliary firmware revision to be updated in the dev_id.json
-# file. It is calculated from the VERSION_ID field which currently has two
-# formats. The revision field is 4 bytes, the first two bytes represent the
-# count of commits from the tagging and next two bytes represent the version.
-# Both fields are represented in BCD encoded format, so 9999 is the maximum
-# value both fields can take. With the format "v2.1-216-ga78ace8", Petitboot
-# would display the firmware revision as "Firmware version: 2.01.02160000",
-# "0216" is count and the revision is "0000". With the format
-# "ibm-v2.0-10-r41-0-gd0c319e" Petitboot would display the firmware revision
-# as "Firmware version: 2.00.00100041", "0010" is count and the revision
-# is "0041".
-
-python do_populate_aux_version() {
-        import json
-        import re
-        version_id = do_get_version(d)
-
-        # count from the commit version
-        count = re.findall("-(\d{1,4})-", version_id)
-
-        release = re.findall("-r(\d{1,4})", version_id)
-        if release:
-            auxVer = count[0] + "{0:0>4}".format(release[0])
-        else:
-            auxVer = count[0] + "0000"
-
-        # Update dev_id.json with the auxiliary firmware revision
-        workdir = d.getVar('WORKDIR', True)
-        file = os.path.join(workdir, 'dev_id.json')
-
-        with open(file, "r+") as jsonFile:
-            data = json.load(jsonFile)
-            jsonFile.seek(0)
-            jsonFile.truncate()
-            data["aux"] = int(auxVer, 16)
-            json.dump(data, jsonFile)
-}
-
-addtask populate_aux_version after do_configure before do_compile
+SRC_URI_append_witherspoon = " \
+	file://occ_sensors.hardcoded.yaml \
+	file://hwmon_sensors.hardcoded.yaml \
+	"