Add bmcweb to meta-ibm layer for redfish support

Put behind nginx and only activate when /redfish is
queried via https.

Testing: Verified that with this change in bmcweb:
https://gerrit.openbmc-project.xyz/#/c/openbmc/bmcweb/+/11518/
that redfish commands can successfully be sent via nginx
on the witherspoon qemu model.

Change-Id: I97509dc3484deffd06c3d60db710eb3b17dfccb5
Signed-off-by: Andrew Geissler <geissonator@yahoo.com>
diff --git a/recipes-phosphor/bmcweb/bmcweb.bbappend b/recipes-phosphor/bmcweb/bmcweb.bbappend
new file mode 100644
index 0000000..b41a1b0
--- /dev/null
+++ b/recipes-phosphor/bmcweb/bmcweb.bbappend
@@ -0,0 +1,10 @@
+SUMMARY = "Modifications to support Nginx"
+
+# Behind NGINX so disable SSL in bmcweb
+EXTRA_OECMAKE += "-DBMCWEB_INSECURE_DISABLE_SSL=ON"
+
+# Only need redfish support
+EXTRA_OECMAKE += "-DBMCWEB_ENABLE_KVM=OFF -DBMCWEB_ENABLE_DBUS_REST=OFF -DBMCWEB_ENABLE_PHOSPHOR_WEBUI=OFF"
+
+# override service and socket file to use nginx
+FILESEXTRAPATHS_prepend := "${THISDIR}/${PN}:"