swift: Add dps310 ambient sensor

Swift has 3 ambient temperature sensors, the dps310 will be labeled as
`ambient1` and initially use the same warn/crit temperature
configurations as Witherspoon.

Tested:
    Built image that contained the config file

Change-Id: I85fd2e44fb4229bee04f6cc4a75613e7945ee754
Signed-off-by: Matthew Barth <msbarth@us.ibm.com>
diff --git a/meta-witherspoon/recipes-phosphor/sensors/phosphor-hwmon_%.bbappend b/meta-witherspoon/recipes-phosphor/sensors/phosphor-hwmon_%.bbappend
index 8ebf37e..c5d75a7 100644
--- a/meta-witherspoon/recipes-phosphor/sensors/phosphor-hwmon_%.bbappend
+++ b/meta-witherspoon/recipes-phosphor/sensors/phosphor-hwmon_%.bbappend
@@ -25,6 +25,7 @@
                bus@1e78a000/i2c-bus@440/tmp275@4a \
                bus@1e78a000/i2c-bus@440/tmp275@48 \
                bus@1e78a000/i2c-bus@300/tmp275@48 \
+               bus@1e78a000/i2c-bus@300/dps310@76 \
                "
 
 ITEMSFMT = "ahb/apb/{0}.conf"