meta-ibm: use ibm-ac-server MACHINEOVERRIDE

Use an override in bbappends in meta-witherspoon as described and
recommended in the "following best practices when creating layers"
section of the the Yocto development tasks manual.

ibm-ac-server represents common machine configuration shared by all of
IBMs "Accelerated Compute" class of servers.  Apply it wherever any
variables are un-bounded by any override.

This enables more flexible use of meta-witherspoon in build
configurations, and easy addition of machines to the layer.

Change-Id: I637588acbaf76f90809b02e48e7fce461b46f6db
Signed-off-by: Brad Bishop <bradleyb@fuzziesquirrel.com>
diff --git a/meta-witherspoon/recipes-phosphor/dbus/phosphor-dbus-monitor-config.bbappend b/meta-witherspoon/recipes-phosphor/dbus/phosphor-dbus-monitor-config.bbappend
index b06da50..185db10 100644
--- a/meta-witherspoon/recipes-phosphor/dbus/phosphor-dbus-monitor-config.bbappend
+++ b/meta-witherspoon/recipes-phosphor/dbus/phosphor-dbus-monitor-config.bbappend
@@ -1,4 +1,4 @@
-PHOSPHOR_DBUS_MONITOR_CONFIGS_append = " fan-policy"
-PHOSPHOR_DBUS_MONITOR_CONFIGS_append = " thermal-policy"
-PHOSPHOR_DBUS_MONITOR_CONFIGS_append = " power-supply-policy"
-PHOSPHOR_DBUS_MONITOR_CONFIGS_append = " events-policy"
+PHOSPHOR_DBUS_MONITOR_CONFIGS_append_ibm-ac-server = " fan-policy"
+PHOSPHOR_DBUS_MONITOR_CONFIGS_append_ibm-ac-server = " thermal-policy"
+PHOSPHOR_DBUS_MONITOR_CONFIGS_append_ibm-ac-server = " power-supply-policy"
+PHOSPHOR_DBUS_MONITOR_CONFIGS_append_ibm-ac-server = " events-policy"