meta-ibm: use ibm-ac-server MACHINEOVERRIDE
Use an override in bbappends in meta-witherspoon as described and
recommended in the "following best practices when creating layers"
section of the the Yocto development tasks manual.
ibm-ac-server represents common machine configuration shared by all of
IBMs "Accelerated Compute" class of servers. Apply it wherever any
variables are un-bounded by any override.
This enables more flexible use of meta-witherspoon in build
configurations, and easy addition of machines to the layer.
Change-Id: I637588acbaf76f90809b02e48e7fce461b46f6db
Signed-off-by: Brad Bishop <bradleyb@fuzziesquirrel.com>
diff --git a/meta-witherspoon/recipes-phosphor/fans/phosphor-fan_%.bbappend b/meta-witherspoon/recipes-phosphor/fans/phosphor-fan_%.bbappend
index 58c1a5f..88c32ff 100644
--- a/meta-witherspoon/recipes-phosphor/fans/phosphor-fan_%.bbappend
+++ b/meta-witherspoon/recipes-phosphor/fans/phosphor-fan_%.bbappend
@@ -1,24 +1,24 @@
FILESEXTRAPATHS_prepend := "${THISDIR}/${BPN}:"
# Package configuration
-FAN_PACKAGES += " \
+FAN_PACKAGES_append_ibm-ac-server = " \
phosphor-cooling-type \
"
-PACKAGECONFIG += "cooling-type"
+PACKAGECONFIG_append_ibm-ac-server = " cooling-type"
TMPL_COOLING = "phosphor-cooling-type@.service"
INSTFMT_COOLING = "phosphor-cooling-type@{0}.service"
COOLING_TGT = "multi-user.target"
FMT_COOLING = "../${TMPL_COOLING}:${COOLING_TGT}.requires/${INSTFMT_COOLING}"
-FILES_phosphor-cooling-type = "${bindir}/phosphor-cooling-type"
-SYSTEMD_SERVICE_phosphor-cooling-type += "${TMPL_COOLING}"
-SYSTEMD_LINK_phosphor-cooling-type += "${@compose_list(d, 'FMT_COOLING', 'OBMC_CHASSIS_INSTANCES')}"
+FILES_phosphor-cooling-type_append_ibm-ac-server = " ${bindir}/phosphor-cooling-type"
+SYSTEMD_SERVICE_phosphor-cooling-type_append_ibm-ac-server = " ${TMPL_COOLING}"
+SYSTEMD_LINK_phosphor-cooling-type_append_ibm-ac-server = " ${@compose_list(d, 'FMT_COOLING', 'OBMC_CHASSIS_INSTANCES')}"
COOLING_ENV_FMT = "obmc/phosphor-fan/phosphor-cooling-type-{0}.conf"
-SYSTEMD_ENVIRONMENT_FILE_phosphor-cooling-type += "${@compose_list(d, 'COOLING_ENV_FMT', 'OBMC_CHASSIS_INSTANCES')}"
+SYSTEMD_ENVIRONMENT_FILE_phosphor-cooling-type_append_ibm-ac-server = " ${@compose_list(d, 'COOLING_ENV_FMT', 'OBMC_CHASSIS_INSTANCES')}"
#These services are protected by the watchdog
SYSTEMD_OVERRIDE_phosphor-fan-control_witherspoon += "fan-watchdog-monitor.conf:phosphor-fan-control-init@0.service.d/fan-watchdog-monitor.conf"