meta-ibm: use ibm-ac-server MACHINEOVERRIDE

Use an override in bbappends in meta-witherspoon as described and
recommended in the "following best practices when creating layers"
section of the the Yocto development tasks manual.

ibm-ac-server represents common machine configuration shared by all of
IBMs "Accelerated Compute" class of servers.  Apply it wherever any
variables are un-bounded by any override.

This enables more flexible use of meta-witherspoon in build
configurations, and easy addition of machines to the layer.

Change-Id: I637588acbaf76f90809b02e48e7fce461b46f6db
Signed-off-by: Brad Bishop <bradleyb@fuzziesquirrel.com>
diff --git a/meta-witherspoon/recipes-phosphor/flash/phosphor-software-manager_%.bbappend b/meta-witherspoon/recipes-phosphor/flash/phosphor-software-manager_%.bbappend
index 13c434d..e106fac 100644
--- a/meta-witherspoon/recipes-phosphor/flash/phosphor-software-manager_%.bbappend
+++ b/meta-witherspoon/recipes-phosphor/flash/phosphor-software-manager_%.bbappend
@@ -1,11 +1,9 @@
-BMC_RW_MTD = "bmc"
-BMC_RO_MTD = "alt-bmc+bmc"
-BMC_KERNEL_MTD = "bmc"
+BMC_RW_MTD_ibm-ac-server = "bmc"
+BMC_RO_MTD_ibm-ac-server = "alt-bmc+bmc"
+BMC_KERNEL_MTD_ibm-ac-server = "bmc"
 
 # Enable signature verification
-PACKAGECONFIG_append_witherspoon = " verify_signature"
-PACKAGECONFIG_append_swift = " verify_signature"
+PACKAGECONFIG_append_ibm-ac-server = " verify_signature"
 
 # Enable sync of persistent files to the alternate BMC chip
-PACKAGECONFIG_append_witherspoon = " sync_bmc_files"
-PACKAGECONFIG_append_swift = " sync_bmc_files"
+PACKAGECONFIG_append_ibm-ac-server = " sync_bmc_files"