meta-ibm: use ibm-ac-server MACHINEOVERRIDE

Use an override in bbappends in meta-witherspoon as described and
recommended in the "following best practices when creating layers"
section of the the Yocto development tasks manual.

ibm-ac-server represents common machine configuration shared by all of
IBMs "Accelerated Compute" class of servers.  Apply it wherever any
variables are un-bounded by any override.

This enables more flexible use of meta-witherspoon in build
configurations, and easy addition of machines to the layer.

Change-Id: I637588acbaf76f90809b02e48e7fce461b46f6db
Signed-off-by: Brad Bishop <bradleyb@fuzziesquirrel.com>
diff --git a/meta-witherspoon/recipes-phosphor/host/p9-host-start.bbappend b/meta-witherspoon/recipes-phosphor/host/p9-host-start.bbappend
index 0eee561..3ae8bcb 100644
--- a/meta-witherspoon/recipes-phosphor/host/p9-host-start.bbappend
+++ b/meta-witherspoon/recipes-phosphor/host/p9-host-start.bbappend
@@ -1,4 +1,4 @@
 RDEPENDS_${PN}_append_witherspoon = " avsbus-control"
 RDEPENDS_${PN}_append_witherspoon = " vrm-control"
-RDEPENDS_${PN}_append = " power-workarounds"
-RDEPENDS_${PN}_remove += "p9-vcs-workaround"
+RDEPENDS_${PN}_append_ibm-ac-server = " power-workarounds"
+RDEPENDS_${PN}_remove_ibm-ac-server = "p9-vcs-workaround"