meta-ibm: use ibm-ac-server MACHINEOVERRIDE

Use an override in bbappends in meta-witherspoon as described and
recommended in the "following best practices when creating layers"
section of the the Yocto development tasks manual.

ibm-ac-server represents common machine configuration shared by all of
IBMs "Accelerated Compute" class of servers.  Apply it wherever any
variables are un-bounded by any override.

This enables more flexible use of meta-witherspoon in build
configurations, and easy addition of machines to the layer.

Change-Id: I637588acbaf76f90809b02e48e7fce461b46f6db
Signed-off-by: Brad Bishop <bradleyb@fuzziesquirrel.com>
diff --git a/meta-witherspoon/recipes-phosphor/inventory/phosphor-inventory-manager_%.bbappend b/meta-witherspoon/recipes-phosphor/inventory/phosphor-inventory-manager_%.bbappend
index 39f8734..bdc3912 100644
--- a/meta-witherspoon/recipes-phosphor/inventory/phosphor-inventory-manager_%.bbappend
+++ b/meta-witherspoon/recipes-phosphor/inventory/phosphor-inventory-manager_%.bbappend
@@ -1,11 +1,11 @@
 FILESEXTRAPATHS_prepend := "${THISDIR}/${PN}:"
-PACKAGECONFIG_append = " associations"
-SRC_URI += "file://associations.json"
+PACKAGECONFIG_append_ibm-ac-server = " associations"
+SRC_URI_append_ibm-ac-server = " file://associations.json"
 
 
-DEPENDS_append = " inventory-cleanup"
+DEPENDS_append_ibm-ac-server = " inventory-cleanup"
 
-do_install_append() {
+do_install_append_ibm-ac-server() {
     install -d ${D}${base_datadir}
     install -m 0755 ${WORKDIR}/associations.json ${D}${base_datadir}/associations.json
 }