meta-ibm: use ibm-ac-server MACHINEOVERRIDE

Use an override in bbappends in meta-witherspoon as described and
recommended in the "following best practices when creating layers"
section of the the Yocto development tasks manual.

ibm-ac-server represents common machine configuration shared by all of
IBMs "Accelerated Compute" class of servers.  Apply it wherever any
variables are un-bounded by any override.

This enables more flexible use of meta-witherspoon in build
configurations, and easy addition of machines to the layer.

Change-Id: I637588acbaf76f90809b02e48e7fce461b46f6db
Signed-off-by: Brad Bishop <bradleyb@fuzziesquirrel.com>
diff --git a/meta-witherspoon/recipes-phosphor/ipmi/phosphor-ipmi-config.bbappend b/meta-witherspoon/recipes-phosphor/ipmi/phosphor-ipmi-config.bbappend
index 3256e83..e3e5002 100644
--- a/meta-witherspoon/recipes-phosphor/ipmi/phosphor-ipmi-config.bbappend
+++ b/meta-witherspoon/recipes-phosphor/ipmi/phosphor-ipmi-config.bbappend
@@ -16,7 +16,7 @@
 unset do_patch[noexec]
 do_patch[depends] = "os-release:do_populate_sysroot"
 
-python do_patch() {
+python do_patch_ibm-ac-server() {
     import json
     import re
     from shutil import copyfile