meta-ibm: use ibm-ac-server MACHINEOVERRIDE

Use an override in bbappends in meta-witherspoon as described and
recommended in the "following best practices when creating layers"
section of the the Yocto development tasks manual.

ibm-ac-server represents common machine configuration shared by all of
IBMs "Accelerated Compute" class of servers.  Apply it wherever any
variables are un-bounded by any override.

This enables more flexible use of meta-witherspoon in build
configurations, and easy addition of machines to the layer.

Change-Id: I637588acbaf76f90809b02e48e7fce461b46f6db
Signed-off-by: Brad Bishop <bradleyb@fuzziesquirrel.com>
diff --git a/meta-witherspoon/recipes-phosphor/mboxd/mboxd_%.bbappend b/meta-witherspoon/recipes-phosphor/mboxd/mboxd_%.bbappend
index ac35ae9..69c9d1d 100644
--- a/meta-witherspoon/recipes-phosphor/mboxd/mboxd_%.bbappend
+++ b/meta-witherspoon/recipes-phosphor/mboxd/mboxd_%.bbappend
@@ -1,12 +1,12 @@
-MBOXD_FLASH_SIZE = "64M"
+MBOXD_FLASH_SIZE_ibm-ac-server = "64M"
 
 FILESEXTRAPATHS_prepend := "${THISDIR}/${PN}:"
 
-SYSTEMD_SERVICE_${PN} += "check-pnor-format.service"
+SYSTEMD_SERVICE_${PN}_append_ibm-ac-server = " check-pnor-format.service"
 
-SRC_URI += "file://check_pnor_format.sh"
+SRC_URI_append_ibm-ac-server = " file://check_pnor_format.sh"
 
-do_install_append() {
+do_install_append_ibm-ac-server() {
 	install -d ${D}${bindir}
 	install -m 0755 ${WORKDIR}/check_pnor_format.sh ${D}${bindir}/check_pnor_format.sh
 }