Add mihawk platform to meta-ibm

The contents of this up-stream include the following items
1.Basic function
2.Led settings
3.GPIO monitor (id button and power supply)
4.Linux dts patch.

Change-Id: Id0d4fd06ed9a9d4abde6c2a68b0a709fde343f60
Signed-off-by: Ben Pai <Ben_Pai@wistron.com>
Signed-off-by: Brad Bishop <bradleyb@fuzziesquirrel.com>
diff --git a/meta-witherspoon/recipes-phosphor/flash/phosphor-software-manager_%.bbappend b/meta-witherspoon/recipes-phosphor/flash/phosphor-software-manager_%.bbappend
index e106fac..61a99fd 100644
--- a/meta-witherspoon/recipes-phosphor/flash/phosphor-software-manager_%.bbappend
+++ b/meta-witherspoon/recipes-phosphor/flash/phosphor-software-manager_%.bbappend
@@ -1,9 +1,14 @@
 BMC_RW_MTD_ibm-ac-server = "bmc"
+BMC_RW_MTD_mihawk = "bmc"
 BMC_RO_MTD_ibm-ac-server = "alt-bmc+bmc"
+BMC_RO_MTD_mihawk = "alt-bmc+bmc"
 BMC_KERNEL_MTD_ibm-ac-server = "bmc"
+BMC_KERNEL_MTD_mihawk = "bmc"
 
 # Enable signature verification
 PACKAGECONFIG_append_ibm-ac-server = " verify_signature"
+PACKAGECONFIG_append_mihawk = " verify_signature"
 
 # Enable sync of persistent files to the alternate BMC chip
 PACKAGECONFIG_append_ibm-ac-server = " sync_bmc_files"
+PACKAGECONFIG_append_mihawk = " sync_bmc_files"