Add mihawk platform to meta-ibm

The contents of this up-stream include the following items
1.Basic function
2.Led settings
3.GPIO monitor (id button and power supply)
4.Linux dts patch.

Change-Id: Id0d4fd06ed9a9d4abde6c2a68b0a709fde343f60
Signed-off-by: Ben Pai <Ben_Pai@wistron.com>
Signed-off-by: Brad Bishop <bradleyb@fuzziesquirrel.com>
diff --git a/meta-witherspoon/recipes-phosphor/logging/mihawk-phosphor-logging-callouts-native.bb b/meta-witherspoon/recipes-phosphor/logging/mihawk-phosphor-logging-callouts-native.bb
new file mode 100644
index 0000000..dcd902b
--- /dev/null
+++ b/meta-witherspoon/recipes-phosphor/logging/mihawk-phosphor-logging-callouts-native.bb
@@ -0,0 +1,20 @@
+SUMMARY = "Mihawk inventory map for phosphor-ipmi-host"
+PR = "r1"
+LICENSE = "Apache-2.0"
+LIC_FILES_CHKSUM = "file://${IBMBASE}/COPYING.apache-2.0;md5=34400b68072d710fecd0a2940a0d1658"
+
+inherit native
+inherit phosphor-logging
+
+SRC_URI += "file://callouts.yaml"
+
+PROVIDES += "virtual/phosphor-logging-callouts"
+
+S = "${WORKDIR}"
+
+do_install() {
+        DEST=${D}${callouts_datadir}
+        install -d ${DEST}
+        install callouts.yaml ${DEST}
+}
+