obmc-libobmc-intf: Add Swift gpio definitions

Add gpio definitions for the Swift machine under a swift subdir.
Move the witherspoon gpio definitions under a witherspoon subdir.

Tested: Built swift and witherspoon and checked that the file
        rootfs/etc/default/obmc/gpio/gpio_defs.json was correct
        for each machine.

Change-Id: I4de5b4e001556cfc02f09959eb371f61f0e3298c
Signed-off-by: Adriana Kobylak <anoo@us.ibm.com>
diff --git a/meta-witherspoon/recipes-phosphor/skeleton/obmc-libobmc-intf_%.bbappend b/meta-witherspoon/recipes-phosphor/skeleton/obmc-libobmc-intf_%.bbappend
index 72d991c..f245296 100644
--- a/meta-witherspoon/recipes-phosphor/skeleton/obmc-libobmc-intf_%.bbappend
+++ b/meta-witherspoon/recipes-phosphor/skeleton/obmc-libobmc-intf_%.bbappend
@@ -1 +1,2 @@
-FILESEXTRAPATHS_prepend := "${THISDIR}/${PN}:"
+FILESEXTRAPATHS_prepend := "${THISDIR}/${PN}/${MACHINE}/"
+FILESEXTRAPATHS_prepend_witherspoon-128 := "${THISDIR}/${PN}/witherspoon:"