meta-romulus: Add id-button.bb

This recipe adds the function to assert/deassert identify LED Group
when the ID button is pressed:
1. Add phosphor-gpio-monitor for the ID button GPIO key;
2. Start id-button-pressed.service when the key is pressed;
3. The service starts a script to check the identify LED group state,
   and assert or de-assert it.

Tested: Assert/De-assert identify LED group by pressing the ID button
        on Romulus.

Change-Id: I782dbc15563a313418aa90bee1f48fc97a6d25fb
Signed-off-by: Lei YU <mine260309@gmail.com>
diff --git a/meta-romulus/recipes-phosphor/packagegroups/packagegroup-obmc-apps.bbappend b/meta-romulus/recipes-phosphor/packagegroups/packagegroup-obmc-apps.bbappend
index 74866b3..55f036c 100644
--- a/meta-romulus/recipes-phosphor/packagegroups/packagegroup-obmc-apps.bbappend
+++ b/meta-romulus/recipes-phosphor/packagegroups/packagegroup-obmc-apps.bbappend
@@ -1 +1 @@
-RDEPENDS_${PN}-inventory += " openpower-occ-control phosphor-cooling-type"
+RDEPENDS_${PN}-inventory += " openpower-occ-control phosphor-cooling-type id-button"