witherspoon:Rename avsbus-workaround to power-workarounds

This service/script will now be used for all required
power workarounds that the BMC needs to apply during
boot. Renaming to support this more generic purpose
of this script.

Change-Id: I9b0fbdff37f6ddc169391f95497d2d69620e552c
Signed-off-by: Andrew Geissler <andrewg@us.ibm.com>
diff --git a/meta-witherspoon/recipes-phosphor/chassis/avsbus-control.bb b/meta-witherspoon/recipes-phosphor/chassis/avsbus-control.bb
index 454601e..a09cdc7 100644
--- a/meta-witherspoon/recipes-phosphor/chassis/avsbus-control.bb
+++ b/meta-witherspoon/recipes-phosphor/chassis/avsbus-control.bb
@@ -7,14 +7,14 @@
 RDEPENDS_${PN} += "i2c-tools"
 
 S = "${WORKDIR}"
-SRC_URI += "file://avsbus-workaround.sh \
+SRC_URI += "file://power-workarounds.sh \
             file://avsbus-enable.sh \
             file://avsbus-disable.sh"
 
 do_install() {
         install -d ${D}${bindir}
-        install -m 0755 ${WORKDIR}/avsbus-workaround.sh \
-            ${D}${bindir}/avsbus-workaround.sh
+        install -m 0755 ${WORKDIR}/power-workarounds.sh \
+            ${D}${bindir}/power-workarounds.sh
         install -m 0755 ${WORKDIR}/avsbus-disable.sh \
             ${D}${bindir}/avsbus-disable.sh
         install -m 0755 ${WORKDIR}/avsbus-enable.sh \
@@ -23,10 +23,10 @@
 
 TMPL_EN= "avsbus-enable@.service"
 TMPL_DIS= "avsbus-disable@.service"
-TMPL_WA= "avsbus-workaround@.service"
+TMPL_WA= "power-workarounds@.service"
 INSTFMT_EN= "avsbus-enable@{0}.service"
 INSTFMT_DIS= "avsbus-disable@{0}.service"
-INSTFMT_WA= "avsbus-workaround@{0}.service"
+INSTFMT_WA= "power-workarounds@{0}.service"
 TGTFMT = "obmc-chassis-poweron@{0}.target"
 FMT_EN = "../${TMPL_EN}:${TGTFMT}.requires/${INSTFMT_EN}"
 FMT_DIS = "../${TMPL_DIS}:${TGTFMT}.requires/${INSTFMT_DIS}"