Add service and recipe for PGOOD fail errors

The service starts the witherspoon-pseq-monitor application.

The service will start right after a power on has been
kicked off and will create an error log if PGOOD doesn't
come on in a certain amount of time.

Future witherspoon-pseq-monitor enhancements will add more
functionality to analyze the power sequencer chip to see
which hardware was the actual cause of the fail.

Resolves openbmc/openbmc#2147

Change-Id: Ia64c59985da57352a007dcaab82d317cdec0fa50
Signed-off-by: Matt Spinler <spinler@us.ibm.com>
diff --git a/meta-witherspoon/recipes-phosphor/packagegroups/packagegroup-obmc-apps.bbappend b/meta-witherspoon/recipes-phosphor/packagegroups/packagegroup-obmc-apps.bbappend
index f2756d0..253c0aa 100644
--- a/meta-witherspoon/recipes-phosphor/packagegroups/packagegroup-obmc-apps.bbappend
+++ b/meta-witherspoon/recipes-phosphor/packagegroups/packagegroup-obmc-apps.bbappend
@@ -1,2 +1,3 @@
 RDEPENDS_${PN}-inventory += "openpower-fru-vpd openpower-occ-control phosphor-cooling-type virtual/obmc-gpio-presence"
 RDEPENDS_${PN}-fan-control += "witherspoon-fan-watchdog"
+RDEPENDS_${PN}-extras += "witherspoon-pfault-analysis"