Add service and recipe for PGOOD fail errors

The service starts the witherspoon-pseq-monitor application.

The service will start right after a power on has been
kicked off and will create an error log if PGOOD doesn't
come on in a certain amount of time.

Future witherspoon-pseq-monitor enhancements will add more
functionality to analyze the power sequencer chip to see
which hardware was the actual cause of the fail.

Resolves openbmc/openbmc#2147

Change-Id: Ia64c59985da57352a007dcaab82d317cdec0fa50
Signed-off-by: Matt Spinler <spinler@us.ibm.com>
diff --git a/meta-witherspoon/recipes-phosphor/power/witherspoon-pfault-analysis-error-native.bb b/meta-witherspoon/recipes-phosphor/power/witherspoon-pfault-analysis-error-native.bb
new file mode 100644
index 0000000..068d792
--- /dev/null
+++ b/meta-witherspoon/recipes-phosphor/power/witherspoon-pfault-analysis-error-native.bb
@@ -0,0 +1,18 @@
+SUMMARY = "Copy error yaml files to known path for elog parsing"
+PR = "r1"
+
+inherit native
+inherit obmc-phosphor-license
+inherit phosphor-dbus-yaml
+
+PROVIDES += "witherspoon-pfault-analysis-error-native"
+require witherspoon-pfault-analysis.inc
+
+S = "${WORKDIR}/git"
+
+do_install_append() {
+    SRC=${S}/xyz/openbmc_project/Power
+    DEST=${yaml_dir}/xyz/openbmc_project/Power
+    install -d ${DEST}
+    install ${SRC}/Fault.errors.yaml ${DEST}
+}