Add service and recipe for PGOOD fail errors

The service starts the witherspoon-pseq-monitor application.

The service will start right after a power on has been
kicked off and will create an error log if PGOOD doesn't
come on in a certain amount of time.

Future witherspoon-pseq-monitor enhancements will add more
functionality to analyze the power sequencer chip to see
which hardware was the actual cause of the fail.

Resolves openbmc/openbmc#2147

Change-Id: Ia64c59985da57352a007dcaab82d317cdec0fa50
Signed-off-by: Matt Spinler <spinler@us.ibm.com>
diff --git a/meta-witherspoon/recipes-phosphor/power/witherspoon-pfault-analysis.bb b/meta-witherspoon/recipes-phosphor/power/witherspoon-pfault-analysis.bb
new file mode 100644
index 0000000..57ee0fe
--- /dev/null
+++ b/meta-witherspoon/recipes-phosphor/power/witherspoon-pfault-analysis.bb
@@ -0,0 +1,31 @@
+SUMMARY = "Witherspoon Power Fault Analysis"
+DESCRIPTION = "Analyzes power devices for faults"
+PR = "r1"
+
+inherit autotools
+inherit pkgconfig
+inherit obmc-phosphor-systemd
+inherit pythonnative
+
+require ${PN}.inc
+
+S = "${WORKDIR}/git"
+
+DEPENDS += " \
+         phosphor-logging \
+         autoconf-archive-native \
+         sdbus++-native \
+         "
+
+RDEPENDS_${PN} += " \
+         phosphor-logging \
+         phosphor-dbus-interfaces \
+         sdbusplus \
+         "
+
+CHASSIS_ON_TGT = "obmc-chassis-poweron@0.target"
+SEQ_PGOOD_SVC = "witherspoon-pseq-monitor-pgood.service"
+SEQ_PGOOD_FMT = "../${SEQ_PGOOD_SVC}:${CHASSIS_ON_TGT}.wants/${SEQ_PGOOD_SVC}"
+
+SYSTEMD_SERVICE_${PN} += "${SEQ_PGOOD_SVC}"
+SYSTEMD_LINK_${PN} += "${SEQ_PGOOD_FMT}"