ibm-logging: use non-native YAML providers

Remove the extra -native YAML provider dependencies and use the
non-native YAML providers obtained via the phosphor-loggging DEPEND.

Add a missing python dependency.

Simplify task dependency between do_report and do_install.

Signed-off-by: Patrick Williams <patrick@stwcx.xyz>
Change-Id: I1e7bc1160a83ba13359c565f1287373bde3171d2
diff --git a/recipes-phosphor/logging/ibm-logging_git.bb b/recipes-phosphor/logging/ibm-logging_git.bb
index 43a20c0..89f8e35 100644
--- a/recipes-phosphor/logging/ibm-logging_git.bb
+++ b/recipes-phosphor/logging/ibm-logging_git.bb
@@ -16,10 +16,11 @@
 inherit phosphor-dbus-yaml
 
 DEPENDS += " \
-         ibm-dbus-interfaces \
-         phosphor-logging \
-         nlohmann-json \
+         ${PYTHON_PN}-pyyaml-native \
          autoconf-archive-native \
+         ibm-dbus-interfaces \
+         nlohmann-json \
+         phosphor-logging \
          sdbusplus \
          "
 
@@ -58,19 +59,10 @@
 
     ${S}/create_error_reports.py \
         -p ${D}/${datadir}/ibm-logging/policy.json \
-        -y ${STAGING_DIR_NATIVE}${yaml_dir} \
+        -y ${STAGING_DIR_TARGET}${yaml_dir} \
         -e ${WORKDIR}/build/all_errors.json \
         -x ${WORKDIR}/build/policy_crosscheck.txt
 
 }
 
-addtask report
-
-#Collect all of the error YAML files into our recipe-sysroot-native dir.
-do_report[depends] = " \
-                     ibm-logging:do_install \
-                     phosphor-logging-error-logs-native:do_populate_sysroot \
-                     phosphor-dbus-interfaces-native:do_populate_sysroot \
-                     openpower-occ-control-native:do_populate_sysroot  \
-                     openpower-debug-collector-native:do_populate_sysroot \
-                     "
+addtask report after do_install