Enable TFTP updates via Redfish

TFTP is already enabled by default using the existing REST api's. Code
was put in recently to also support TFTP via the Redfish
UpdateServices.SimpleUpdate object. By default this is disabled within
bmcweb. Enable it by default on all IBM systems to keep parity
with the existing REST api's

Tested:
curl -k -H "X-Auth-Token: $TOKEN" -X GET
https://${BMC_IP}/redfish/v1/UpdateService
{
  "@odata.context": "/redfish/v1/$metadata#UpdateService.UpdateService",
  "@odata.id": "/redfish/v1/UpdateService",
  "@odata.type": "#UpdateService.v1_2_0.UpdateService",
  "Actions": {
    "#UpdateService.SimpleUpdate": {
      "TransferProtocol@Redfish.AllowableValues": [
        "TFTP"
      ],
      "target":
"/redfish/v1/UpdateService/Actions/UpdateService.SimpleUpdate"
    }

Change-Id: I5d8b433ba7938a3e21f84b2d5fa22c7f62ecd818
Signed-off-by: Andrew Geissler <geissonator@yahoo.com>
diff --git a/recipes-phosphor/bmcweb/bmcweb_%.bbappend b/recipes-phosphor/bmcweb/bmcweb_%.bbappend
new file mode 100644
index 0000000..44f4f46
--- /dev/null
+++ b/recipes-phosphor/bmcweb/bmcweb_%.bbappend
@@ -0,0 +1,3 @@
+EXTRA_OECMAKE_append = " \
+    -DBMCWEB_INSECURE_ENABLE_REDFISH_FW_TFTP_UPDATE=ON \
+"