meta-romulus: phosphor-hwmon workaround for fan speed

Romulus uses aspeed pwm and fan tacho, and its driver returns ETIMEDOUT
for fan speed when host is off, which causes phosphor-hwmon exit with
excpetion for fan_tacho sensors.

The workaround is to handle ETIMEDOUT and make it return -ETIMEDOUT
value for the sensor.

Change-Id: I1c6252c7f0ba1c932948397a9398ff80dfb71e9d
Signed-off-by: Lei YU <mine260309@gmail.com>
diff --git a/meta-romulus/recipes-phosphor/sensors/phosphor-hwmon%.bbappend b/meta-romulus/recipes-phosphor/sensors/phosphor-hwmon%.bbappend
index eb5e223..bbd977f 100644
--- a/meta-romulus/recipes-phosphor/sensors/phosphor-hwmon%.bbappend
+++ b/meta-romulus/recipes-phosphor/sensors/phosphor-hwmon%.bbappend
@@ -1,5 +1,12 @@
 FILESEXTRAPATHS_prepend := "${THISDIR}/${PN}:"
 
+# Pin the revision so the patch is guaranteed to be appliable
+# TODO: Remove this when the error handling in hwmon is done:
+# https://gerrit.openbmc-project.xyz/#/c/8073/
+SRCREV = "26d21731c292a02ec71480fade9a06658160eafb"
+
+SRC_URI += " file://0001-sysfs-Return-ETIMEDOUT-instead-of-throw-exception.patch"
+
 OCCS = " \
        sbefifo@2400/occ@1/occ-hwmon@1 \
        hub@3400/cfam@1,0/sbefifo@2400/occ@2/occ-hwmon@2 \