Remove witherspoon prefix from pfault-analysis

Remove the witherspoon prefix from the witherspoon-pfault-analysis based
recipes for applications and service files to avoid confusion when these
are reused by Swift.

Point to latest commit of witherspoon-pfault-analysis.

Requires:
    I4c7275c3b14b3b3724abb98b8d43610df4f9c2a3
    https://gerrit.openbmc-project.xyz/c/openbmc/witherspoon-pfault-analysis/+/19399

Change-Id: Ic6c8c78b9bddc363a34eb2246bffd094ff1008de
Signed-off-by: Brandon Wyman <bjwyman@gmail.com>
diff --git a/meta-witherspoon/recipes-phosphor/power/witherspoon-pfault-analysis_git.bb b/meta-witherspoon/recipes-phosphor/power/witherspoon-pfault-analysis_git.bb
index c507657..51086c6 100644
--- a/meta-witherspoon/recipes-phosphor/power/witherspoon-pfault-analysis_git.bb
+++ b/meta-witherspoon/recipes-phosphor/power/witherspoon-pfault-analysis_git.bb
@@ -21,21 +21,21 @@
          "
 
 CHASSIS_ON_TGT = "obmc-chassis-poweron@0.target"
-SEQ_MONITOR_SVC = "witherspoon-pseq-monitor.service"
+SEQ_MONITOR_SVC = "pseq-monitor.service"
 SEQ_MONITOR_FMT = "../${SEQ_MONITOR_SVC}:${CHASSIS_ON_TGT}.wants/${SEQ_MONITOR_SVC}"
 
-SEQ_PGOOD_SVC = "witherspoon-pseq-monitor-pgood.service"
+SEQ_PGOOD_SVC = "pseq-monitor-pgood.service"
 SEQ_PGOOD_FMT = "../${SEQ_PGOOD_SVC}:${CHASSIS_ON_TGT}.wants/${SEQ_PGOOD_SVC}"
 
 SYSTEMD_SERVICE_${PN} += "${SEQ_MONITOR_SVC} ${SEQ_PGOOD_SVC}"
 SYSTEMD_LINK_${PN} += "${SEQ_MONITOR_FMT} ${SEQ_PGOOD_FMT}"
 
-PSU_MONITOR_TMPL = "witherspoon-power-supply-monitor@.service"
-PSU_MONITOR_INSTFMT = "witherspoon-power-supply-monitor@{0}.service"
+PSU_MONITOR_TMPL = "power-supply-monitor@.service"
+PSU_MONITOR_INSTFMT = "power-supply-monitor@{0}.service"
 PSU_MONITOR_TGT = "multi-user.target"
 PSU_MONITOR_FMT = "../${PSU_MONITOR_TMPL}:${PSU_MONITOR_TGT}.requires/${PSU_MONITOR_INSTFMT}"
 
-FILES_witherspoon-psu-monitor = "${sbindir}/witherspoon-psu-monitor"
+FILES_psu-monitor = "${bindir}/psu-monitor"
 SYSTEMD_SERVICE_${PN} += "${PSU_MONITOR_TMPL}"
 SYSTEMD_LINK_${PN} += "${@compose_list(d, 'PSU_MONITOR_FMT', 'OBMC_POWER_SUPPLY_INSTANCES')}"