blob: 7d577cc383275ab919b90de9e73a843d8e8d810a [file] [log] [blame]
Matt Spinlerc1037472016-12-20 09:28:21 -06001SUMMARY = "Witherspoon VRM Overrides"
2DESCRIPTION = "Sets Witherspoon VRMs to custom voltages"
3PR = "r1"
4
5inherit obmc-phosphor-systemd
6inherit obmc-phosphor-license
7
8RDEPENDS_${PN} += "i2c-tools bash"
9
10S = "${WORKDIR}"
11SRC_URI += "file://vrm-control.sh"
12
13do_install() {
14 install -d ${D}${bindir}
15 install -m 0755 ${WORKDIR}/vrm-control.sh ${D}${bindir}/vrm-control.sh
16}
17
18TMPL = "vrm-control@.service"
19INSTFMT = "vrm-control@{0}.service"
Andrew Geissler556185a2017-01-30 12:47:59 -060020TGTFMT = "obmc-power-chassis-on@{0}.target"
Matt Spinlerc1037472016-12-20 09:28:21 -060021FMT = "../${TMPL}:${TGTFMT}.wants/${INSTFMT}"
22
23SYSTEMD_SERVICE_${PN} += "${TMPL}"
24SYSTEMD_LINK_${PN} += "${@compose_list(d, 'FMT', 'OBMC_CHASSIS_INSTANCES')}"