blob: 542bd943149fed9d244346fc49fa1deb043e22ba [file] [log] [blame]
Lei YUb3cb3812016-12-22 16:15:03 +08001SUMMARY = "Romulus CPLD Trigger"
2DESCRIPTION = "Romulus power on workaround to trigger CPLD to continue power sequence"
3PR = "r0"
4
5inherit obmc-phosphor-systemd
6inherit obmc-phosphor-license
7
8RDEPENDS_${PN} += "obmc-pydevtools"
9
10PROVIDES += 'virtual/p9-vcs-workaround'
11RPROVIDES_${PN} += 'virtual-p9-vcs-workaround'
12
13S = "${WORKDIR}"
14SRC_URI += "file://cpld_trigger.sh"
15
16do_install() {
17 install -d ${D}${bindir}
18 install -m 0755 ${WORKDIR}/cpld_trigger.sh ${D}${bindir}/cpld_trigger.sh
19}
20
21TMPL = "cpld_trigger@.service"
22INSTFMT = "cpld_trigger@{0}.service"
Lei YUd43ec212017-02-14 16:47:45 +080023TGTFMT = "obmc-power-chassis-on@{0}.target"
Lei YUb3cb3812016-12-22 16:15:03 +080024FMT = "../${TMPL}:${TGTFMT}.wants/${INSTFMT}"
25
26SYSTEMD_SERVICE_${PN} += "${TMPL}"
27SYSTEMD_LINK_${PN} += "${@compose_list(d, 'FMT', 'OBMC_CHASSIS_INSTANCES')}"
28