fp5280g2: Add led manager configure

Use the "init-ok" gpio to notify CPLD that the BMC has been initialized. CPLD will cause the power button led to blink.

Tested: When BMC is booted complete, the power button will blink

Signed-off-by: Chicago Duan <duanzhijia01@inspur.com>
Change-Id: Iab9e0f3dfa941928afafa1c01e15069bb97b5aac
diff --git a/meta-fp5280g2/recipes-phosphor/leds/fp5280g2-led-manager-config-native.bb b/meta-fp5280g2/recipes-phosphor/leds/fp5280g2-led-manager-config-native.bb
new file mode 100644
index 0000000..22aadad
--- /dev/null
+++ b/meta-fp5280g2/recipes-phosphor/leds/fp5280g2-led-manager-config-native.bb
@@ -0,0 +1,19 @@
+SUMMARY = "Phosphor LED Group Management for fp5280g2"
+PR = "r1"
+LICENSE = "Apache-2.0"
+LIC_FILES_CHKSUM = "file://${COREBASE}/meta/files/common-licenses/Apache-2.0;md5=89aea4e17d99a7cacdbeed46a0096b10"
+
+inherit native
+
+PROVIDES += "virtual/phosphor-led-manager-config-native"
+
+SRC_URI += "file://led.yaml"
+S = "${WORKDIR}"
+
+# Overwrite the example led layout yaml file prior
+# to building the phosphor-led-manager package
+do_install() {
+    SRC=${S}
+    DEST=${D}${datadir}/phosphor-led-manager
+    install -D ${SRC}/led.yaml ${DEST}/led.yaml
+}