fp5280g2: Load LED manager with JSON configuration

Since the led manager used the default YAML to generated led-gen.hpp and
creates D-Bus object for the groups, and we tend to use JSON instead of
YAML to create it.

Tested: built successfully on phosphor-led-manager and create D-Bus
object used JSON configuration.

Signed-off-by: George Liu <liuxiwei@inspur.com>
Change-Id: I7e15f56ec055c69e06259b0391810f5dcce89715
diff --git a/meta-fp5280g2/recipes-phosphor/leds/phosphor-led-manager_%.bbappend b/meta-fp5280g2/recipes-phosphor/leds/phosphor-led-manager_%.bbappend
new file mode 100644
index 0000000..a122a72
--- /dev/null
+++ b/meta-fp5280g2/recipes-phosphor/leds/phosphor-led-manager_%.bbappend
@@ -0,0 +1,12 @@
+FILESEXTRAPATHS_prepend := "${THISDIR}/${PN}:"
+
+SRC_URI += "file://led-group-config.json"
+
+EXTRA_OECONF = "--enable-use_json"
+
+DEPENDS += "phosphor-dbus-interfaces"
+
+do_install_append() {
+        install -d ${D}${datadir}/phosphor-led-manager/
+        install -m 0644 ${WORKDIR}/led-group-config.json ${D}${datadir}/phosphor-led-manager/
+}