Add a service-config-manager recipe

It points to upstream code now.

Tested:
It builds.

Change-Id: I1f436b118e4951488697d5bdcf55dabae8c56e2e
Signed-off-by: AppaRao Puli <apparao.puli@linux.intel.com>
diff --git a/meta-common/recipes-core/service-config-manager/service-config-manager_git.bb b/meta-common/recipes-core/service-config-manager/service-config-manager_git.bb
new file mode 100644
index 0000000..bbd73a1
--- /dev/null
+++ b/meta-common/recipes-core/service-config-manager/service-config-manager_git.bb
@@ -0,0 +1,28 @@
+SUMMARY = "Service configuration manager daemon to control service properties"
+DESCRIPTION = "Daemon controls service properies like port, channels, state etc.."
+
+LICENSE = "Apache-2.0"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=7becf906c8f8d03c237bad13bc3dac53"
+inherit cmake systemd
+
+SRC_URI = "git://github.com/openbmc/service-config-manager"
+
+PV = "0.1+git${SRCPV}"
+SRCREV = "33816cf9125737e9ec931961bad2924a6104c5bb"
+
+S = "${WORKDIR}/git"
+
+SYSTEMD_SERVICE_${PN} = "srvcfg-manager.service"
+
+DEPENDS += " \
+    systemd \
+    sdbusplus \
+    sdbusplus-native \
+    phosphor-logging \
+    boost \
+    "
+RDEPENDS_${PN} += " \
+    libsystemd \
+    sdbusplus \
+    phosphor-logging \
+    "