meta-intel: add intel suffix to recipes

Add a suffix, "intel" to all common intel recipe changes.  The suffix is
defined in intel.inc, which is included already in the s2600wf machine
conf and likely any platform including meta-intel.

Signed-off-by: Patrick Venture <venture@google.com>
Change-Id: I8113e8eb494548f5f8fff9888a9ad2e1a086a942
diff --git a/meta-common/recipes-phosphor/fans/phosphor-pid-control_%.bbappend b/meta-common/recipes-phosphor/fans/phosphor-pid-control_%.bbappend
index 3e89746..4521fe8 100644
--- a/meta-common/recipes-phosphor/fans/phosphor-pid-control_%.bbappend
+++ b/meta-common/recipes-phosphor/fans/phosphor-pid-control_%.bbappend
@@ -1,5 +1,5 @@
-FILESEXTRAPATHS_prepend := "${THISDIR}/${PN}:"
+FILESEXTRAPATHS_prepend_intel := "${THISDIR}/${PN}:"
 
 inherit obmc-phosphor-systemd
-SYSTEMD_SERVICE_${PN} = "phosphor-pid-control.service"
-EXTRA_OECONF = "--enable-configure-dbus=yes"
+SYSTEMD_SERVICE_${PN}_intel = "phosphor-pid-control.service"
+EXTRA_OECONF_intel = "--enable-configure-dbus=yes"