Add bmcweb target to S2600Wf

This changeset replaces phosphor rest with bmcweb for the s2600wf
target.  bmcweb has several advantages over phosphor-rest.
1. Written in C++.
2. Supports Asyncronous transactions
3. Authentication backed by PAM
4. SSL key generation, and modern SSL cipher suites
See the application readme for more

To enable bmcweb, this patchset also:
1. Revs libtinyxml to the latest version 6.0.0 from the existing 3.0.0
2. Adds the boost-dbus recipe, to allow bmcweb to build.  Bmcweb is a
header only dbus library.

Change-Id: I5b90427977709127c09fedcfc4bcb713908d356f
Signed-off-by: Ed Tanous <ed.tanous@intel.com>
diff --git a/meta-common/recipes-intel/boost-dbus/boost-dbus.bb b/meta-common/recipes-intel/boost-dbus/boost-dbus.bb
new file mode 100644
index 0000000..c523416
--- /dev/null
+++ b/meta-common/recipes-intel/boost-dbus/boost-dbus.bb
@@ -0,0 +1,15 @@
+LICENSE = "BSL-1.0"
+LIC_FILES_CHKSUM = "file://LICENSE_1_0.txt;md5=e4224ccaecb14d942c71d31bef20d78c"
+
+SRC_URI = "gitsm://github.com/openbmc/boost-dbus.git"
+
+PV = "1.0+git${SRCPV}"
+SRCREV = "165e3f02c7d5d418c1b5f8c180ae970d6a8afb3a"
+
+S = "${WORKDIR}/git"
+
+DEPENDS = "dbus boost gtest "
+
+inherit cmake
+
+FILES_${PN}-dev += "${libdir}/cmake/boost-dbus/*"