convert sysfs gpio usage to libgpod

Add dependency of libgpiod because intel ipmi oemcommands needs it.

Signed-off-by: Zhikui Ren <zhikui.ren@intel.com>
Change-Id: I3586aec65218212e96de9a26e1c8fd023dffbb40
diff --git a/meta-common/recipes-intel/ipmi/intel-ipmi-oem_git.bb b/meta-common/recipes-intel/ipmi/intel-ipmi-oem_git.bb
index 27c6c7f..ae4c31e 100755
--- a/meta-common/recipes-intel/ipmi/intel-ipmi-oem_git.bb
+++ b/meta-common/recipes-intel/ipmi/intel-ipmi-oem_git.bb
@@ -10,7 +10,7 @@
 S = "${WORKDIR}/git"
 PV = "0.1+git${SRCPV}"
 
-DEPENDS = "boost phosphor-ipmi-host phosphor-logging systemd intel-dbus-interfaces"
+DEPENDS = "boost phosphor-ipmi-host phosphor-logging systemd intel-dbus-interfaces libgpiod"
 
 inherit cmake obmc-phosphor-ipmiprovider-symlink