meta-lanyang: add IPMI recipe

Add CPU, DIMM and Motherboard inventory for Lanyang machine

Change-Id: Ib8bcf5c5313eb53ab130e8adbba71a8f78cb0ad4
Tested: Built the IPMI recipe then read the information of the CPU,
	DIMM and Motherboard's inventory after power on.
Signed-off-by: Brian Yang <yang.brianc.w@inventec.com>
diff --git a/meta-lanyang/recipes-phosphor/ipmi/lanyang-ipmi-inventory-map-native.bb b/meta-lanyang/recipes-phosphor/ipmi/lanyang-ipmi-inventory-map-native.bb
new file mode 100644
index 0000000..7a155c2
--- /dev/null
+++ b/meta-lanyang/recipes-phosphor/ipmi/lanyang-ipmi-inventory-map-native.bb
@@ -0,0 +1,23 @@
+SUMMARY = "Lanyang IPMI to DBus Inventory mapping."
+PR = "r1"
+
+inherit native
+inherit obmc-phosphor-license
+inherit phosphor-ipmi-fru
+
+SRC_URI += "file://config.yaml"
+
+PROVIDES += "virtual/phosphor-ipmi-fru-inventory"
+
+S = "${WORKDIR}"
+
+do_install() {
+        # TODO: install this to inventory_datadir
+        # after ipmi-fru-parser untangles the host
+        # firmware config from the machine inventory.
+        DEST=${D}${config_datadir}
+
+        install -d ${DEST}
+        install config.yaml ${DEST}
+}
+