meta-lanyang: add AVSBus script, services

Add AVSBus control script.
Add systemd services to enable AVSBus after power on and disable AVSBus
at power off.
Add bitbake recipe to install script and services.
Remove p9-vcs-workaround in the lanyang.conf and p9-host-start.bbappend
because there is no UCD on lanyang platform.

Change-Id: I3508776ff2b3ef5378af840f096d1cc4420f5062
Tested: built image correctly then can boot to host.
Signed-off-by: Brian Yang <yang.brianc.w@inventec.com>
diff --git a/meta-lanyang/recipes-phosphor/chassis/avsbus-control.bb b/meta-lanyang/recipes-phosphor/chassis/avsbus-control.bb
new file mode 100644
index 0000000..ff68f39
--- /dev/null
+++ b/meta-lanyang/recipes-phosphor/chassis/avsbus-control.bb
@@ -0,0 +1,28 @@
+SUMMARY = "Lanyang AVSBus control"
+DESCRIPTION = "Voltage regulator module (VRM) AVSBus control for Lanyang"
+PR = "r0"
+
+inherit obmc-phosphor-systemd
+inherit obmc-phosphor-license
+
+TMPL_OFF = "avsbus-disable@.service"
+TMPL_ON = "avsbus-enable@.service"
+INSTFMT_OFF = "avsbus-disable@{0}.service"
+INSTFMT_ON = "avsbus-enable@{0}.service"
+TGTFMT_OFF = "obmc-host-stop@{0}.target"
+TGTFMT_ON = "obmc-chassis-poweron@{0}.target"
+FMT_OFF = "../${TMPL_OFF}:${TGTFMT_OFF}.wants/${INSTFMT_OFF}"
+FMT_ON = "../${TMPL_ON}:${TGTFMT_ON}.requires/${INSTFMT_ON}"
+
+SYSTEMD_SERVICE_${PN} += "${TMPL_OFF}"
+SYSTEMD_LINK_${PN} += "${@compose_list(d, 'FMT_OFF', 'OBMC_CHASSIS_INSTANCES')}"
+SYSTEMD_SERVICE_${PN} += "${TMPL_ON}"
+SYSTEMD_LINK_${PN} += "${@compose_list(d, 'FMT_ON', 'OBMC_CHASSIS_INSTANCES')}"
+
+SRC_URI += "file://lanyang_avsbus.sh"
+RDEPENDS_${PN} += "i2c-tools"
+
+do_install() {
+        install -d ${D}${bindir}
+        install -m 0755 ${WORKDIR}/lanyang_avsbus.sh ${D}${bindir}/lanyang_avsbus.sh
+}