meta-lenovo: hr855xg2: ipmi-flash use mapped addr var

Use the IPMI_FLASH_BMC_ADDRESS mapped address variable to configure the
mapped_address configuration option.

Signed-off-by: Patrick Venture <venture@google.com>
Change-Id: I7d0aff6c77b9cd673a8348c9856cee5706345be2
diff --git a/meta-hr855xg2/recipes-phosphor/ipmi/phosphor-ipmi-flash_%.bbappend b/meta-hr855xg2/recipes-phosphor/ipmi/phosphor-ipmi-flash_%.bbappend
index 229e26d..01549f5 100644
--- a/meta-hr855xg2/recipes-phosphor/ipmi/phosphor-ipmi-flash_%.bbappend
+++ b/meta-hr855xg2/recipes-phosphor/ipmi/phosphor-ipmi-flash_%.bbappend
@@ -2,4 +2,6 @@
 #Licensed under BSD-3, see COPYING.BSD file for details."
 
 FILESEXTRAPATHS_prepend_hr855xg2 := "${THISDIR}/${PN}:"
-EXTRA_OECONF_append_hr855xg2 = " --enable-static-layout --enable-lpc-bridge --enable-aspeed-lpc --enable-reboot-update MAPPED_ADDRESS=0x98000000"
+EXTRA_OECONF_append_hr855xg2 = " --enable-static-layout --enable-lpc-bridge --enable-aspeed-lpc --enable-reboot-update"
+
+IPMI_FLASH_BMC_ADDRESS_hr855xg2 = "0x98000000"