meta-nuvoton: generate full flash image.

Nuvoton's full flash image includes also a bootloader called Bootblock,
and headers for it and for the u-boot. Generating headers and merging
the Bootblock and the u-boot are being done by Nuvoton's binary
generator tool (Bingo), which uses external paramteres from XML files
for that.

Change-Id: Idcd7ab42fa358e44d3908410d6913d4a915d5faa
Signed-off-by: Oshri Alkoby (NTIL) <oshri.alkoby@nuvoton.com>
diff --git a/recipes-bsp/images/npcm7xx-bootblock.bb b/recipes-bsp/images/npcm7xx-bootblock.bb
new file mode 100644
index 0000000..85b8070
--- /dev/null
+++ b/recipes-bsp/images/npcm7xx-bootblock.bb
@@ -0,0 +1,19 @@
+LICENSE = "CLOSED"
+LIC_FILES_CHKSUM = ""
+
+SRCREV = "10.09.05"
+FILENAME = "Poleg_bootblock.bin"
+
+SRC_URI = "git://github.com/Nuvoton-Israel/npcm7xx-bootblock;protocol=git"
+SRC_URI[md5sum] = "cf8daa5f4636ed1ff952618e435af028"
+
+S = "${WORKDIR}/git"
+
+inherit deploy
+
+do_deploy () {
+	install -d ${DEPLOYDIR}
+	install -m 644 ${FILENAME} ${DEPLOYDIR}/
+}
+
+addtask deploy before do_build after do_compile