meta-nuvoton: add npcm7xx-igps recipe

Fetch the XML files which describe how to assemble the bootloaders for
an NPCM7XX BMC.

Apply a patch which changes the image paths to work with our BitBake
build environment. The original files are intended to be used with
custom Python build scripts which place the intermediate images at
different paths than we use.

Change-Id: Ica2703ddf96078ff033e6febea03f1d4bb8d8126
Signed-off-by: Benjamin Fair <benjaminfair@google.com>
diff --git a/recipes-bsp/images/npcm7xx-igps-native_02.01.12.bb b/recipes-bsp/images/npcm7xx-igps-native_02.01.12.bb
new file mode 100644
index 0000000..c04d92a
--- /dev/null
+++ b/recipes-bsp/images/npcm7xx-igps-native_02.01.12.bb
@@ -0,0 +1,25 @@
+SUMMARY = "Image Generation and Programming Scripts for NPCM7XX (Poleg) devices"
+DESCRIPTION = "Image Generation and Programming Scripts for NPCM7XX (Poleg) devices"
+HOMEPAGE = "https://github.com/Nuvoton-Israel/igps"
+LICENSE = "GPLv2"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=b234ee4d69f5fce4486a80fdaf4a4263"
+
+SRC_URI = " \
+    git://github.com/Nuvoton-Israel/igps \
+    file://0001-Adjust-paths-for-use-with-Bitbake.patch \
+"
+# tag IGPS_02.01.12
+SRCREV = "2fb1a3b0d61164ed1157e27889a4ec2292cbc760"
+
+S = "${WORKDIR}/git"
+
+DEST = "${D}${datadir}/${BPN}"
+
+do_install() {
+	install -d ${DEST}
+	install ImageGeneration/references/BootBlockAndHeader_${IGPS_MACHINE}.xml ${DEST}
+	install ImageGeneration/references/UbootHeader_${IGPS_MACHINE}.xml ${DEST}
+	install ImageGeneration/inputs/mergedBootBlockAndUboot.xml ${DEST}
+}
+
+inherit native