u-boot-nuvoton: split common vars into an include file

Move the common variables from u-boot-nuvoton and
u-boot-fw-utils-nuvoton into a shared include file. This matches
Aspeed's U-Boot and makes it easier to update the SRCREV.

Change-Id: I33b949f98ecdb40aa05b43706327c63a3faec340
Signed-off-by: Benjamin Fair <benjaminfair@google.com>
diff --git a/recipes-bsp/u-boot/u-boot-fw-utils-nuvoton_git.bb b/recipes-bsp/u-boot/u-boot-fw-utils-nuvoton_git.bb
index cefdea8..42bc7a3 100644
--- a/recipes-bsp/u-boot/u-boot-fw-utils-nuvoton_git.bb
+++ b/recipes-bsp/u-boot/u-boot-fw-utils-nuvoton_git.bb
@@ -1,19 +1,10 @@
+require u-boot-common-nuvoton.inc
+
 SUMMARY = "U-Boot bootloader fw_printenv/setenv utilities"
-LICENSE = "GPLv2+"
-LIC_FILES_CHKSUM = "file://Licenses/README;md5=a2c678cfd4a4d97135585cad908541c6"
-SECTION = "bootloader"
 DEPENDS = "mtd-utils"
 
 PROVIDES += "u-boot-fw-utils"
 
-UBRANCH = "npcm7xx"
-SRC_URI = "git://github.com/Nuvoton-Israel/u-boot.git;branch=${UBRANCH}"
-SRCREV = "196461383f7d043f18cab3bb34dded89fba4712a"
-
-PV .= "+${UBRANCH}+"
-
-S = "${WORKDIR}/git"
-
 INSANE_SKIP_${PN} = "already-stripped"
 
 EXTRA_OEMAKE_class-target = 'CROSS_COMPILE="${TARGET_PREFIX}" HOSTCC="${BUILD_CC} ${BUILD_FLAGS} ${BUILD_LDFLAGS}" CC="${CC} ${CFLAGS} ${LDFLAGS}" STRIP=true V=1'