ipmi-oem: Rename openpower ipmi oem recipe
Rename host-ipmid-oem to openpower-ipmi-oem as this is an OpenPower
specific IPMI plugin.
Move to the OpenPOWER layer.
Change-Id: Idf0de216a4a49f6ad377001052abfce13dd20aaf
Signed-off-by: Brad Bishop <bradleyb@fuzziesquirrel.com>
diff --git a/common/recipes-phosphor/ipmi/openpower-ipmi-oem.bb b/common/recipes-phosphor/ipmi/openpower-ipmi-oem.bb
new file mode 100644
index 0000000..da36ba4
--- /dev/null
+++ b/common/recipes-phosphor/ipmi/openpower-ipmi-oem.bb
@@ -0,0 +1,20 @@
+SUMMARY = "Phosphor OpenBMC OEM Commands for OpenPOWER systems"
+DESCRIPTION = "Phosphor OpenBMC IPMI OEM commands for OpenPOWER based systems"
+HOMEPAGE = "https://github.com/openbmc/openpower-host-ipmi-oem"
+PR = "r1"
+
+inherit autotools pkgconfig
+inherit obmc-phosphor-license
+
+DEPENDS += "host-ipmid"
+DEPENDS += "autoconf-archive-native"
+
+TARGET_CFLAGS += "-fpic"
+
+SRC_URI += "git://github.com/openbmc/openpower-host-ipmi-oem"
+SRCREV = "70dbc5871c6da23f7f14046ce9d356600992f6a8"
+
+S = "${WORKDIR}/git"
+
+FILES_${PN}_append = " ${libdir}/host-ipmid/lib*${SOLIBS}"
+FILES_${PN}-dev_append = " ${libdir}/host-ipmid/lib*${SOLIBSDEV} ${libdir}/host-ipmid/*.la"