meta-openpower: Define i2c-occ feature
OpenPOWER P8 systems uses i2c to access occ.
Define i2c-occ OBMC_MACHINE_FEATURES and append EXTRA_OECONF in
openpower-occ-control.bb so that it compiles with I2C OCC support.
Enabled this feature on Palmetto first.
Change-Id: I1c07d28494fc5e87e86a3be1bfcfd955770e14e7
Signed-off-by: Lei YU <mine260309@gmail.com>
diff --git a/common/recipes-phosphor/occ/openpower-occ-control.bb b/common/recipes-phosphor/occ/openpower-occ-control.bb
index d03601f..e1823fe 100644
--- a/common/recipes-phosphor/occ/openpower-occ-control.bb
+++ b/common/recipes-phosphor/occ/openpower-occ-control.bb
@@ -29,4 +29,6 @@
phosphor-dbus-interfaces \
"
+EXTRA_OECONF_append = "${@bb.utils.contains('OBMC_MACHINE_FEATURES', 'i2c-occ', ' --enable-i2c-occ', '', d)}"
+
S = "${WORKDIR}/git"