OCC: Update Service name

Since the occ-control daemon now handles more than
just pass-through, changing the service name mapping
to that functionality.

Also added some dependencies needed by latest commit

Change-Id: Ie4c1f74e6f417d1754eab13d6a7aa6aaeb09ab7f
Signed-off-by: Vishwanatha Subbanna <vishwa@linux.vnet.ibm.com>
diff --git a/common/recipes-phosphor/occ/openpower-occ-control.bb b/common/recipes-phosphor/occ/openpower-occ-control.bb
index 58c3735..d03601f 100644
--- a/common/recipes-phosphor/occ/openpower-occ-control.bb
+++ b/common/recipes-phosphor/occ/openpower-occ-control.bb
@@ -10,13 +10,14 @@
 
 require ${PN}.inc
 
-DBUS_SERVICE_${PN} += "org.open_power.OCC.PassThrough.service"
+DBUS_SERVICE_${PN} += "org.open_power.OCC.Control.service"
 
 DEPENDS += " \
         sdbusplus \
         sdbusplus-native \
         phosphor-logging \
         openpower-dbus-interfaces \
+        phosphor-dbus-interfaces \
         openpower-dbus-interfaces-native \
         autoconf-archive-native \
         "
@@ -25,6 +26,7 @@
                sdbusplus \
                phosphor-logging \
                openpower-dbus-interfaces \
+               phosphor-dbus-interfaces \
                "
 
 S = "${WORKDIR}/git"