Change wants to requires for all critical services
In order for targets to fail when their services fail,
the relationship must be a "requires"
Change-Id: I1523dd51af8817b473557bac65e9e71eacecf52e
Signed-off-by: Andrew Geissler <andrewg@us.ibm.com>
diff --git a/meta-ibm/meta-witherspoon/recipes-phosphor/chassis/vcs-pre-post.bb b/meta-ibm/meta-witherspoon/recipes-phosphor/chassis/vcs-pre-post.bb
index 1cebcc7..ec7eeca 100644
--- a/meta-ibm/meta-witherspoon/recipes-phosphor/chassis/vcs-pre-post.bb
+++ b/meta-ibm/meta-witherspoon/recipes-phosphor/chassis/vcs-pre-post.bb
@@ -33,10 +33,10 @@
INSTFMT_UCD = "ucd_disable_vcs@{0}.service"
TGTFMT = "obmc-power-chassis-on@{0}.target"
TGTFMT_OFF= "obmc-power-chassis-off@{0}.target"
-FMT_OFF = "../${TMPL_OFF}:${TGTFMT}.wants/${INSTFMT_OFF}"
-FMT_ON = "../${TMPL_ON}:${TGTFMT}.wants/${INSTFMT_ON}"
-FMT_UCD = "../${TMPL_UCD}:${TGTFMT}.wants/${INSTFMT_UCD}"
-FMT_OFF_PO = "../${TMPL_OFF_PO}:${TGTFMT_OFF}.wants/${INSTFMT_OFF_PO}"
+FMT_OFF = "../${TMPL_OFF}:${TGTFMT}.requires/${INSTFMT_OFF}"
+FMT_ON = "../${TMPL_ON}:${TGTFMT}.requires/${INSTFMT_ON}"
+FMT_UCD = "../${TMPL_UCD}:${TGTFMT}.requires/${INSTFMT_UCD}"
+FMT_OFF_PO = "../${TMPL_OFF_PO}:${TGTFMT_OFF}.requires/${INSTFMT_OFF_PO}"
SYSTEMD_SERVICE_${PN} += "${TMPL_OFF}"
SYSTEMD_LINK_${PN} += "${@compose_list(d, 'FMT_OFF', 'OBMC_CHASSIS_INSTANCES')}"