openpower: add recipe for openpower-hw-diags
Support for monitoring the attention gpio and handling attention
events.
Change-Id: I02d1d4b230bf031837c0a285b232920e2c693076
Signed-off-by: Brad Bishop <bradleyb@fuzziesquirrel.com>
Signed-off-by: Ben Tyner <ben.tyner@ibm.com>
diff --git a/recipes-phosphor/logging/openpower-hw-diags_git.bb b/recipes-phosphor/logging/openpower-hw-diags_git.bb
new file mode 100644
index 0000000..78ad535
--- /dev/null
+++ b/recipes-phosphor/logging/openpower-hw-diags_git.bb
@@ -0,0 +1,17 @@
+inherit meson systemd
+
+SUMMARY = "ATTN and HwDiags Support"
+DESCRIPTION = "Attention Handler and Hardware Diagnostics"
+LICENSE = "Apache-2.0"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=86d3f3a95c324c9479bd8986968f4327"
+
+SRC_URI = "git://github.com/projects/openbmc/openpower-hw-diags"
+
+SYSTEMD_SERVICE_${PN} = "attn_handler.service"
+PV = "0.1+git${SRCPV}"
+SRCREV = "73ac368a7e435b27d1100037eb76ee65f6a85ce6"
+
+S = "${WORKDIR}/git"
+
+DEPENDS = "boost libgpiod pdbg phosphor-logging sdbusplus"
+FILES_${PN} += "${UNITDIR}/attn_handler.service"