Switch to phosphor-buttons for button handling

Use the 2 button packages from the phosphor-buttons repo for
button press handling:

obmc-phosphor-buttons-signals
- Sends signals when buttons are pressed and released

obmc-phosphor-buttons-handler
- Listens for the signals and performs the corresponding
  actions, which are the same as the current button code
  that lives in skeleton.

These support the power, host reset, and ID buttons, All buttons are
optional, and for a button to be configured its GPIO must reside in
/etc/default/obmc/gpio/gpio_defs.json.  If the GPIO isn't found, then
nothing will listen for those button presses.  See the phosphor-buttons
code for the naming requirements.

Tested: Built and ran image.

Change-Id: I01f65b8abe04decd69c76f56bb49e3f4c478de33
Signed-off-by: Matt Spinler <spinler@us.ibm.com>
diff --git a/recipes-phosphor/packagegroups/packagegroup-op-apps.bb b/recipes-phosphor/packagegroups/packagegroup-op-apps.bb
index 421789d..cdbc3f0 100644
--- a/recipes-phosphor/packagegroups/packagegroup-op-apps.bb
+++ b/recipes-phosphor/packagegroups/packagegroup-op-apps.bb
@@ -24,8 +24,8 @@
 
 SUMMARY_${PN}-chassis = "OpenPOWER Chassis"
 RDEPENDS_${PN}-chassis = " \
-        obmc-button-power \
-        obmc-button-reset \
+        obmc-phosphor-buttons-signals \
+        obmc-phosphor-buttons-handler \
         obmc-control-chassis \
         obmc-op-control-power \
         obmc-host-failure-reboots \