Memory preserve reboot: recipe updates for mpreboot.

start_host@.service: Update to start_host service to skip it during
a memory preserve reboot
op-proc-control-systemd-links.bb: update to install services
op-proc-control_git.bb: Added mpreboot services
Bump openpower-proc-control SRCREV to required commit

Signed-off-by: Dhruvaraj Subhashchandran <dhruvaraj@in.ibm.com>
Change-Id: Iac292a9cd39cc537413459e915b0398bad26054a
diff --git a/recipes-phosphor/host/op-proc-control-systemd-links.bb b/recipes-phosphor/host/op-proc-control-systemd-links.bb
index 8185ddf..46fdbbc 100644
--- a/recipes-phosphor/host/op-proc-control-systemd-links.bb
+++ b/recipes-phosphor/host/op-proc-control-systemd-links.bb
@@ -14,6 +14,8 @@
 pkg_postinst_${PN}() {
 	mkdir -p $D$systemd_system_unitdir/obmc-host-stop@0.target.wants
 	mkdir -p $D$systemd_system_unitdir/obmc-host-force-warm-reboot@0.target.requires
+	mkdir -p $D$systemd_system_unitdir/obmc-host-startmin@0.target.requires
+	mkdir -p $D$systemd_system_unitdir/obmc-host-diagnostic-mode@0.target.requires
 
 	LINK="$D$systemd_system_unitdir/obmc-host-stop@0.target.wants/op-stop-instructions@0.service"
 	TARGET="../op-stop-instructions@.service"
@@ -30,6 +32,14 @@
 		TARGET="../cfam_override@.service"
 		ln -s $TARGET $LINK
 	fi
+
+	LINK="$D$systemd_system_unitdir/obmc-host-startmin@0.target.requires/op-continue-mpreboot@0.service"
+	TARGET="../op-continue-mpreboot@.service"
+	ln -s $TARGET $LINK
+
+	LINK="$D$systemd_system_unitdir/obmc-host-diagnostic-mode@0.target.requires/op-enter-mpreboot@0.service"
+	TARGET="../op-enter-mpreboot@.service"
+	ln -s $TARGET $LINK
 }
 
 pkg_prerm_${PN}() {
@@ -42,4 +52,8 @@
 		LINK="$D$systemd_system_unitdir/obmc-host-startmin@0.target.requires/cfam_override@0.service"
 		rm $LINK
 	fi
+	LINK="$D$systemd_system_unitdir/obmc-host-startmin@0.target.requires/op-continue-mpreboot@0.service"
+	rm $LINK
+	LINK="$D$systemd_system_unitdir/obmc-host-diagnostic-mode@0.target.requires/op-enter-mpreboot@0.service"
+	rm $LINK
 }