warm-reboot: stop instr and cfam reset
Install the new stop instructions and cfam reset services required for a
warm reboot into the appropriate target
Includes following in bump:
Andrew Geissler (4):
warm-reboot: ensure sbe start bit is 0
warm reboot: stop instructions support
warm-reboot: add cfam-reset capabilities
warm-reboot: cfam-reset service
Signed-off-by: Andrew Geissler <geissonator@yahoo.com>
Change-Id: I2e3b1e4306e56f7193c0e1564b07ade7e4fcce9f
diff --git a/recipes-phosphor/host/op-proc-control-systemd-links.bb b/recipes-phosphor/host/op-proc-control-systemd-links.bb
new file mode 100644
index 0000000..cd4f63b
--- /dev/null
+++ b/recipes-phosphor/host/op-proc-control-systemd-links.bb
@@ -0,0 +1,32 @@
+SUMMARY = "OpenPOWER processor control services installation"
+PR = "r1"
+
+LICENSE = "Apache-2.0"
+LIC_FILES_CHKSUM = "file://${COREBASE}/meta/files/common-licenses/Apache-2.0;md5=89aea4e17d99a7cacdbeed46a0096b10"
+
+inherit allarch
+
+RDEPENDS_${PN} += "op-proc-control"
+RDEPENDS_${PN} += "phosphor-state-manager-obmc-targets"
+
+ALLOW_EMPTY_${PN} = "1"
+
+pkg_postinst_${PN}() {
+ mkdir -p $D$systemd_system_unitdir/obmc-host-stop@0.target.requires
+ mkdir -p $D$systemd_system_unitdir/obmc-host-force-warm-reboot@0.target.requires
+
+ LINK="$D$systemd_system_unitdir/obmc-host-stop@0.target.requires/op-stop-instructions@0.service"
+ TARGET="../op-stop-instructions@.service"
+ ln -s $TARGET $LINK
+
+ LINK="$D$systemd_system_unitdir/obmc-host-force-warm-reboot@0.target.requires/op-cfam-reset.service"
+ TARGET="../op-cfam-reset.service"
+ ln -s $TARGET $LINK
+}
+
+pkg_prerm_${PN}() {
+ LINK="$D$systemd_system_unitdir/obmc-host-stop@0.target.requires/op-stop-instructions@0.service"
+ rm $LINK
+ LINK="$D$systemd_system_unitdir/obmc-host-force-warm-reboot@0.target.requires/op-cfam-reset.service"
+ rm $LINK
+}