Add FSI enable/disable services for cronus use
Start fsi-disable.service to unbind the FSI Driver.
Start fsi-enable.service to bind it again and rescan.
Also added a fsi-bind@.service so we can ensure the
driver is bound each power on.
Change-Id: I5fa62b44994aea3bb645e755187f29e720bf3bce
Signed-off-by: Matt Spinler <spinler@us.ibm.com>
diff --git a/common/recipes-phosphor/packagegroups/packagegroup-op-apps.bb b/common/recipes-phosphor/packagegroups/packagegroup-op-apps.bb
index d5a542a..b9d974c 100644
--- a/common/recipes-phosphor/packagegroups/packagegroup-op-apps.bb
+++ b/common/recipes-phosphor/packagegroups/packagegroup-op-apps.bb
@@ -33,8 +33,8 @@
obmc-watchdog \
obmc-host-failure-reboots \
"
-#Pull in obmc-fsi-scan on all P9 OpenPOWER systems
-RDEPENDS_${PN}-chassis += "${@mf_enabled(d, 'obmc-fsi-scan', 'obmc-fsi-scan')}"
+#Pull in obmc-fsi on all P9 OpenPOWER systems
+RDEPENDS_${PN}-chassis += "${@mf_enabled(d, 'obmc-fsi', 'obmc-fsi')}"
SUMMARY_${PN}-fans = "OpenPOWER Fans"
RDEPENDS_${PN}-fans = " \