meta-openpower: first-boot-set-hostname: use BPN

Avoid a new QA warning:

SRC_URI uses PN not BPN [src-uri-bad]

Change-Id: I339104889417ac8b3c6eb8eca77324dcf82c8bc0
Signed-off-by: Adriana Kobylak <anoo@us.ibm.com>
diff --git a/recipes-phosphor/network/first-boot-set-hostname_1.0.bb b/recipes-phosphor/network/first-boot-set-hostname_1.0.bb
index 1e9fdd6..7f71e7c 100644
--- a/recipes-phosphor/network/first-boot-set-hostname_1.0.bb
+++ b/recipes-phosphor/network/first-boot-set-hostname_1.0.bb
@@ -10,13 +10,13 @@
 
 SYSTEMD_SERVICE_${PN} = "first-boot-set-hostname.service"
 
-SRC_URI = "file://${PN}.sh file://${PN}.service"
+SRC_URI = "file://${BPN}.sh file://${BPN}.service"
 
 S = "${WORKDIR}"
 do_install() {
-    sed "s/{MACHINE}/${MACHINE}/" -i ${PN}.sh
+    sed "s/{MACHINE}/${MACHINE}/" -i ${BPN}.sh
     install -d ${D}${bindir} ${D}${systemd_system_unitdir}
-    install ${PN}.sh ${D}${bindir}/
-    install -m 644 ${PN}.service ${D}${systemd_system_unitdir}/
+    install ${BPN}.sh ${D}${bindir}/
+    install -m 644 ${BPN}.service ${D}${systemd_system_unitdir}/
 }